Welcome Guest ( Log In | Register )


Bump Topic Add Reply RSS Feed New Topic New Poll

Outline · [ Standard ] · Linear+

> Car overheat going uphill

dinor01
post Jan 6 2019, 10:55 PM, updated 2 months ago

Getting Started
**
Group: Junior Member
Posts: 286

Joined: Mar 2008
my myvi engine temperature started going up when during on the hill, to be exact when i on the way to bentong. which pass by the karak highway genting sempah.
i straigtht away switch off the air cond and the temperature going down .
driving in town during traffic jam and idle all seem normal.

i have service the radiator but on the way back to KL it having the same issue.

anyone encounter this before?

HonMun
post Jan 6 2019, 11:07 PM

Professor
*****
Group: Senior Member
Posts: 961

Joined: Nov 2005
From: Malaysia


FAN, Radiator or thermostat
ledtechn
post Jan 6 2019, 11:18 PM

New Member
*
Group: Junior Member
Posts: 24

Joined: Jun 2011
Could be waterpump or radiator fan

This post has been edited by ledtechn: Jan 6 2019, 11:19 PM
System Error Message
post Jan 6 2019, 11:35 PM

Enthusiast
*****
Group: Senior Member
Posts: 834

Joined: Jul 2010
Check coolent levels, pump and radiator fan. Make sure all the parts are clean and unpainted as well even the front grill.

Best way to test, in the hot sun put the aircon to full/max, how cold is it? also how hot is the radiator? If the radiator is not hot then you have a problem with the coolent/flow. A hot radiator means that the cooling system is working well since the delta between engine and radiator is lower. In modern cars the radiator is typically a centralised cooler for many different parts, so the flow bit is important too same with coolent levels, check it regularly if you are having problems as well, you can also do a coolent system flush and make sure there is no dirt or anything stuck inside.

Make sure you use both the proper coolent and right engine oil.
dinor01
post Jan 7 2019, 06:31 AM

Getting Started
**
Group: Junior Member
Posts: 286

Joined: Mar 2008
QUOTE(HonMun @ Jan 6 2019, 11:07 PM)
FAN, Radiator or thermostat
*
i just change the thermostat few months back.
after services the radiator still the issue happen.
fan is working fine during city drive. will it only failed during going uphill?

dinor01
post Jan 7 2019, 06:32 AM

Getting Started
**
Group: Junior Member
Posts: 286

Joined: Mar 2008
QUOTE(ledtechn @ Jan 6 2019, 11:18 PM)
Could be waterpump or radiator fan
*
waterpump? mechanic said coolant no leaking. and noway to chek its condition.

dinor01
post Jan 7 2019, 06:34 AM

Getting Started
**
Group: Junior Member
Posts: 286

Joined: Mar 2008
QUOTE(System Error Message @ Jan 6 2019, 11:35 PM)
Check coolent levels, pump and radiator fan. Make sure all the parts are clean and unpainted as well even the front grill.

Best way to test, in the hot sun put the aircon to full/max, how cold is it? also how hot is the radiator? If the radiator is not hot then you have a problem with the coolent/flow. A hot radiator means that the cooling system is working well since the delta between engine and radiator is lower. In modern cars the radiator is typically a centralised cooler for many different parts, so the flow bit is important too same with coolent levels, check it regularly if you are having problems as well, you can also do a coolent system flush and make sure there is no dirt or anything stuck inside.

Make sure you use both the proper coolent and right engine oil.
*
Air cond is ok on the hot sun.
Already service the radiator but still it happen again only during uphill.
checking coolant level and still the same...meaning no leaking.
Daylight2018
post Jan 7 2019, 07:02 AM

New Member
*
Group: Newbie
Posts: 0

Joined: Jun 2018
QUOTE(dinor01 @ Jan 7 2019, 06:32 AM)
waterpump? mechanic said coolant no leaking. and noway to chek its condition.
*
Some ppl, car hit 100k km immediately change waternpump regardless its condition
It is called preventive maintenance.
ledtechn
post Jan 7 2019, 07:17 AM

New Member
*
Group: Junior Member
Posts: 24

Joined: Jun 2011
QUOTE(dinor01 @ Jan 7 2019, 06:32 AM)
waterpump? mechanic said coolant no leaking. and noway to chek its condition.
*
To check it need to remove it. Because the blade inside might be gone already due to corrosion. So it is not pumping enough coolant at high engine rpm and causing overheat.
Chrix
post Jan 7 2019, 08:17 AM

Getting Started
**
Group: Junior Member
Posts: 107

Joined: Nov 2006
Try this:

Ensure coolant level is correct.

Proceed to go uphill til you notice the temp is higher than normal.
Check the engine bay for any signs of coolant (try not check this as fast as you can, before it dries up)
Sometimes minor leaks, and will worsen when engine is under load (eg; going up hill in your case.

I faced this issue previously, no signs of leak until engine under load uphill, then there is coolant squirting from one side of the rad.
mushigen
post Jan 7 2019, 08:21 AM

Casual
***
Group: Junior Member
Posts: 312

Joined: Jul 2010


I'd start with the cheapest fix: change radiator cap. Make sure you get the one with proper pressure rating.
Old cap may not be able to hold pressure.
HonMun
post Jan 7 2019, 10:26 AM

Professor
*****
Group: Senior Member
Posts: 961

Joined: Nov 2005
From: Malaysia


Change radiator directly, flushing radiator sometimes doesn't resolve the issue.
Jessieccy
post Jan 7 2019, 11:47 AM

New Member
*
Group: Junior Member
Posts: 13

Joined: Nov 2014
Could be the Radiator water hose. Got a friend had same problem on his 1st gen Myvi, eventually was the Hose collapse/flatten, water got restricted and couldnt flow properly.
System Error Message
post Jan 7 2019, 01:25 PM

Enthusiast
*****
Group: Senior Member
Posts: 834

Joined: Jul 2010
QUOTE(dinor01 @ Jan 7 2019, 06:34 AM)
Air cond is ok on the hot sun.
Already service the radiator but still it happen again only during uphill.
checking coolant level and still the same...meaning no leaking.
*
But what about coolent flow, make sure you check that.

Other than what one above mention where hose flatten, check that theres no blockages and check the pumps, service/change them if needed. It really just sounds like you're lacking coolent flow.
kurangak
post Jan 7 2019, 01:29 PM

certified /k addict
*****
Group: Senior Member
Posts: 772

Joined: Apr 2011
From: here and there



QUOTE(dinor01 @ Jan 6 2019, 10:55 PM)
my myvi engine temperature started going up when during on the hill, to be exact when i on the way to bentong. which pass by the karak highway genting sempah.
i straigtht away switch off the air cond and the temperature going down .
driving in town during traffic jam and idle all seem normal.

i have service the radiator but on the way back to KL it having the same issue.

anyone encounter this before?
*
check thermostat and waterpump next
dinor01
post Jan 11 2019, 03:34 PM

Getting Started
**
Group: Junior Member
Posts: 286

Joined: Mar 2008
QUOTE(Daylight2018 @ Jan 7 2019, 07:02 AM)
Some ppl, car hit 100k  km immediately change waternpump regardless its condition
It is called preventive maintenance.
*
Ok.. Will try to change the water pump and see how..
dinor01
post Jan 11 2019, 03:35 PM

Getting Started
**
Group: Junior Member
Posts: 286

Joined: Mar 2008
QUOTE(System Error Message @ Jan 7 2019, 01:25 PM)
But what about coolent flow, make sure you check that.

Other than what one above mention where hose flatten, check that theres no blockages and check the pumps, service/change them if needed. It really just sounds like you're lacking coolent flow.
*
Might just change the hose as well is change water pump
1tanmee
post Jan 17 2019, 10:09 AM

On my way
****
Group: Senior Member
Posts: 622

Joined: Jul 2016
QUOTE(dinor01 @ Jan 6 2019, 10:55 PM)
my myvi engine temperature started going up when during on the hill, to be exact when i on the way to bentong. which pass by the karak highway genting sempah.
i straigtht away switch off the air cond and the temperature going down .
driving in town during traffic jam and idle all seem normal.

i have service the radiator but on the way back to KL it having the same issue.

anyone encounter this before?
*
I expect it to be the opposite. Cranking up aircon fan should cool down the temp kan?
unitron
post Jan 17 2019, 10:21 AM

W1(R)3d
*******
Group: Senior Member
Posts: 2,227

Joined: Jan 2003
From: In the shadows behind you



QUOTE(dinor01 @ Jan 7 2019, 06:31 AM)
i just change the thermostat few months back.
after services the radiator still the issue happen.
fan is working fine during city drive. will it only failed during going uphill?
*
I think you need to bring back to the mechanic... clearly something not done right when he replaced the thermostat / service the cooling system.
My guess is maybe cooling system bleed wasn't done until all air is released.
mushigen
post Jan 17 2019, 11:38 AM

Casual
***
Group: Junior Member
Posts: 312

Joined: Jul 2010


QUOTE(1tanmee @ Jan 17 2019, 10:09 AM)
I expect it to be the opposite. Cranking up aircon fan should cool down the temp kan?
*
I think you confused aircon with heater kan?

2 Pages  1 2 >Top


Bump Topic Add ReplyOptions New Topic
 

Switch to:
| Lo-Fi Version
0.0687sec    3.86    5 queries    GZIP Disabled
Time is now: 23rd March 2019 - 02:39 AM