Welcome Guest ( Log In | Register )

Outline · [ Standard ] · Linear+

 Problem with Proton Gen2, helps

views
     
dares
post Nov 8 2012, 09:25 PM

Enthusiast
*****
Junior Member
780 posts

Joined: Jul 2011
QUOTE(THE CLASS OF 13 @ Nov 8 2012, 09:00 PM)
u mean throttle delay ka? whenever want to shift gear after pijak the clutch the rpm go higher right? that is because of drive by wire system bro..same with my saga flx oso..if happen when idle i dunno..maybe got problem with ur engine.
*
2009 post bro sweat.gif sweat.gif
THE CLASS OF 13
post Nov 8 2012, 10:46 PM

Getting Started
**
Junior Member
160 posts

Joined: Nov 2009


QUOTE(dares @ Nov 8 2012, 09:25 PM)
2009 post bro  sweat.gif  sweat.gif
*
ya after realise no turning back..cannot delete..damn..haha
adam_1979
post Dec 2 2012, 01:23 AM

New Member
*
Newbie
0 posts

Joined: Dec 2012


my Gen 2 problem

1- Temperature high when i on air cond
2- when start the engine must press the accelerator pedal after changing water pump
3- while driving less engine speed after changing water pump

what should i do..........pls icon_question.gif
keanutan
post Dec 2 2012, 02:47 AM

New Member
*
Newbie
4 posts

Joined: Apr 2010
QUOTE(adam_1979 @ Dec 2 2012, 01:23 AM)
my Gen 2 problem

1- Temperature high when i on air cond
2- when start the engine must press the accelerator pedal after changing water pump
3- while driving less engine speed after changing water pump

what should i do..........pls icon_question.gif
*
Change radiator cap first and before that check ur radiator fan aircond fan and water pump . Happen to me on my seg change radiator cap all back to normal
ikengkai
post Apr 7 2014, 11:09 AM

Getting Started
**
Junior Member
247 posts

Joined: Oct 2007
Hi,
I guess it outdated post, but very informative.

I just did major services with timing belt, water pump, tensioner changed to my gen2 manual.
The problem now is when release the clutch, the engine RPM will suddenly drop to 200-300 rpm. Can hear the engine will low rpm and going to shut off (50-60% when slow down car to stop, and pressing the clutch will get this).

The horrible thing is, there is few times the campro engine shut off and engine light on, when I press the clutch. I need to quickly switch the key to off, and turn ignition on to start back the engine. And imagine the challenge when this happen on the road... smile.gif

Do you guys have any idea, before I go back to the mechanic? I use outside mechanic to change all those stuff.

I will try the remove battery wire method to reset ECU and see how thing go on.



QUOTE(keanutan @ Dec 2 2012, 02:47 AM)
Change radiator cap first and before that check ur radiator fan aircond fan and water pump . Happen to me on my seg change radiator cap all back to normal
*
lemer
post Apr 7 2014, 12:21 PM

New Member
*
Newbie
0 posts

Joined: Dec 2013
To solve the problem is easy, sell the car and get Preve, a safer car.
arza04
post Apr 7 2014, 02:19 PM

Getting Started
**
Junior Member
292 posts

Joined: Nov 2013
QUOTE(ikengkai @ Apr 7 2014, 11:09 AM)
Hi,
I guess it outdated post, but very informative.

I just did major services with timing belt, water pump, tensioner changed to my gen2 manual.
The problem now is when release the clutch, the engine RPM will suddenly drop to 200-300 rpm. Can hear the engine will low rpm and going to shut off (50-60% when slow down car to stop, and pressing the clutch will get this).

The horrible thing is, there is few times the campro engine shut off and engine light on, when I press the clutch. I need to quickly switch the key to off, and turn ignition on to start back the engine. And imagine the challenge when this happen on the road... smile.gif

Do you guys have any idea, before I go back to the mechanic? I use outside mechanic to change all those stuff.

I will try the remove battery wire method to reset ECU and see how thing go on.
*
Go to Proton SC, let them plug in device to check the code. Clear the ECU fault code wont solve the problem
Most likely your o2 sensor kong, but anyway just go to Proton sc to let them diagnose


QUOTE(lemer @ Apr 7 2014, 12:21 PM)
To solve the problem is easy, sell the car and get Preve, a safer car.
*
We live in a world that money is earned not falls from the skies
Thrust
post Apr 7 2014, 09:31 PM

Power To The People!!!
*******
Senior Member
3,594 posts

Joined: Oct 2005


QUOTE(ikengkai @ Apr 7 2014, 11:09 AM)
Hi,
I guess it outdated post, but very informative.

I just did major services with timing belt, water pump, tensioner changed to my gen2 manual.
The problem now is when release the clutch, the engine RPM will suddenly drop to 200-300 rpm. Can hear the engine will low rpm and going to shut off (50-60% when slow down car to stop, and pressing the clutch will get this).

The horrible thing is, there is few times the campro engine shut off and engine light on, when I press the clutch. I need to quickly switch the key to off, and turn ignition on to start back the engine. And imagine the challenge when this happen on the road... smile.gif

Do you guys have any idea, before I go back to the mechanic? I use outside mechanic to change all those stuff.

I will try the remove battery wire method to reset ECU and see how thing go on.
*
Try to clean your IACV (Idle Air Control Valve).. Usually thats the thing that causes idle to drop below the intended rpm.
ikengkai
post Apr 7 2014, 10:02 PM

Getting Started
**
Junior Member
247 posts

Joined: Oct 2007
More test result.

Car left idling without a/c turn on - no problem, work good and no low rpm, stay at 900++ rpm.
Car left idling, turn on a/c - no problem, when a/c compressor on, the rpm stay at 950 - 1000 rpm. After a/c disengage, it remain 900++ rpm.

Drive at 30-50 km/h cruising, without pressing break, press the clutch, and rpm dip to 200-300 rpm and bounce back 900+. Tested 10 times and will get engine "mati" once.... Almost every time the same scenario (around cruising speed and press clutch) engine will low to 200-300 rpm and bounce back to 900+ rpm. Intermittently will hear engine like want to mati due to low rpm. Once awhile will get the real engine mati. Need quickly switch key to off, and turn on ignition to get engine alive.

Will ask the same mechanic whether could tune the idling rpm higher? If there is no any tuning for campro, then need send to Proton SC.

icon_question.gif

QUOTE(Thrust @ Apr 7 2014, 09:31 PM)
Try to clean your IACV (Idle Air Control Valve).. Usually thats the thing that causes idle to drop below the intended rpm.
*
lemer
post Apr 8 2014, 06:21 AM

New Member
*
Newbie
0 posts

Joined: Dec 2013
QUOTE(arza04 @ Apr 7 2014, 02:19 PM)
Go to Proton SC, let them plug in device to check the code. Clear the ECU fault code wont solve the problem
Most likely your o2 sensor kong, but anyway just go to Proton sc to let them diagnose
We live in a world that money is earned not falls from the skies
*
That's why i told that, sometimes it will be cheaper with new affordable car like Preve manual executive come with 3years free services than maintaining old car.
arza04
post Apr 8 2014, 06:34 AM

Getting Started
**
Junior Member
292 posts

Joined: Nov 2013
QUOTE(lemer @ Apr 8 2014, 06:21 AM)
That's why i told that, sometimes it will be cheaper with new affordable car like Preve manual executive come with 3years free services than maintaining old car.
*
LOL, ts probably have finish paying car loan and here you recommend him to take another debt

ikengkai, just go for ecu diagnose..the sensor tells you what problem
ikengkai
post Apr 8 2014, 10:51 AM

Getting Started
**
Junior Member
247 posts

Joined: Oct 2007
The car loan got settle. And it a less than 10 years first hand gen2.
since it working good, no plan to change. I rather spend 2-3k repair per year than buy new car for RM65k++ (example: Preve) and possible to get unknown headache issue. The problem I facing now also due to major services (timing belt, tensioner, water pump, 4-to-1 ekzos to remove catalytic converter). Once I manage to fix this issue, I think it will serve me well again. smile.gif

Even to get a new car, proton will not in the list. Sorry to proton fan. I know the car is okay and value for money, but the overall perception, I will go for non-proton. Just my personal preference, after I experience first own proton's car (do not count car from parents, friend... bla bla, this truly I drive it everyday)

By the way, my gen2 serve me good for 10 years, with unavoidable problem/issues (steering clock spring, door handle broken, power-windows fixture, aircon compressor jam, bad low rpm torque and kena engine mati at traffic light, ekzos tailpipe rusted), at least it meet my min requirement - no break-down on road.


QUOTE(lemer @ Apr 8 2014, 06:21 AM)
That's why i told that, sometimes it will be cheaper with new affordable car like Preve manual executive come with 3years free services than maintaining old car.
*
This post has been edited by ikengkai: Apr 8 2014, 10:56 AM
lemer
post Apr 8 2014, 11:08 AM

New Member
*
Newbie
0 posts

Joined: Dec 2013
QUOTE(ikengkai @ Apr 8 2014, 10:51 AM)
The car loan got settle. And it a less than 10 years first hand gen2.
since it working good, no plan to change. I rather spend 2-3k repair per year than buy new car for RM65k++ (example: Preve) and possible to get unknown headache issue. The problem I facing now also due to major services (timing belt, tensioner, water pump, 4-to-1 ekzos to remove catalytic converter). Once I manage to fix this issue, I think it will serve me well again.  smile.gif

Even to get a new car, proton will not in the list. Sorry to proton fan. I know the car is okay and value for money, but the overall perception, I will go for non-proton. Just my personal preference, after I experience first own proton's car (do not count car from parents, friend... bla bla, this truly I drive it everyday) 

By the way, my gen2 serve me good for 10 years, with unavoidable problem/issues (steering clock spring, door handle broken, power-windows fixture, aircon compressor jam, bad low rpm torque and kena engine mati at traffic light, ekzos tailpipe rusted), at least it meet my min requirement - no break-down on road.
*
Wow very good car, 10 years with that car yet never give you breakdown on the rood. And that is Gen 2 first car release from Proton built in house. You can imagine what Preve will be good for you.
SUSbudakdegilz
post Apr 8 2014, 02:10 PM

Regular
******
Senior Member
1,138 posts

Joined: Dec 2006



Did you change your exhaust header at the same time as u do major service(timing belt etc)
Yup maybe it had to do with your ECU..check with proton sc or you also can try at some workshop which they have the PDT(proton diagnosis tools)
ikengkai
post Apr 8 2014, 04:41 PM

Getting Started
**
Junior Member
247 posts

Joined: Oct 2007
Yes, do all in one go.
Had try unplug battery cable to reset the ECU, now observe how it going... at the moment look good, if till weekend and never happen again, then problem should be consider resolve. If not, then need go visit SC.


QUOTE(budakdegilz @ Apr 8 2014, 02:10 PM)
Did you change your exhaust header at the same time as u do major service(timing belt etc)
Yup maybe it had to do with your ECU..check with proton sc or you also can try at some workshop which they have the PDT(proton diagnosis tools)
*
SUSbudakdegilz
post Apr 8 2014, 06:38 PM

Regular
******
Senior Member
1,138 posts

Joined: Dec 2006



QUOTE(ikengkai @ Apr 8 2014, 04:41 PM)
Yes, do all in one go.
Had try unplug battery cable to reset the ECU, now observe how it going... at the moment look good, if till weekend and never happen again, then problem should be consider resolve. If not, then need go visit SC.
*
maybe your ecu is on "relearning" process
i not quite sure about gen2 ECU...maybe it use 16 bit...same as my BLM
so "relearning" will take some time...

p/s:
i also face the same problem like you when i did change my timing belt..
mine is worst because auto..detect it early and not far from the workshop...
so the workshop did a PDT test...no error code...
take out battery terminal also didn't solve it...
so they try taking out the TB(throttle body) and clean it...
and no more problem...already 1 month plus...
ikengkai
post Apr 14 2014, 09:17 PM

Getting Started
**
Junior Member
247 posts

Joined: Oct 2007
Hi budakdegilz,
You are right. I went to proton service center. The tech just drove my car, then he take out spark-plug and remove the throttle body to wash. From him, it very common issue for campro engine. After high mileage, sure will kena throttle related problem, all sort of weird behavior like mati engine while cornering and etc.

After washing throttle body, change spark plug, and pluged in device - relearning throttle body setting, reinit bla bla.... low timing issue resolved.

Now, the campro engine like *new* engine, where when release clutch, it will rev the rpm higher for some time..... good thing is no mati engine problem, bad thing, quite hard to drive and need use to it again..


QUOTE(budakdegilz @ Apr 8 2014, 06:38 PM)
maybe your ecu is on "relearning" process
i not quite sure about gen2 ECU...maybe it use 16 bit...same as my BLM
so "relearning" will take some time...

p/s:
i also face the same problem like you when i did change my timing belt..
mine is worst because auto..detect it early and not far from the workshop...
so the workshop did a PDT test...no error code...
take out battery terminal also didn't solve it...
so they try taking out the TB(throttle body) and clean it...
and no more problem...already 1 month plus...
*
ikengkai
post Apr 24 2014, 04:28 PM

Getting Started
**
Junior Member
247 posts

Joined: Oct 2007
Update: After 1 week plus, my gen2 run good and no repeat problem.
markymark15
post Jun 30 2016, 12:45 AM

New Member
*
Newbie
0 posts

Joined: Jun 2016
Further to all these problems,I need to replace the crankshaft sensor on my 2009 Gen 2 1.6.Can anyone tell me where this is located on the engine,please?
Many thanks
tanchong
post Aug 24 2016, 08:39 PM

New Member
*
Junior Member
22 posts

Joined: Mar 2007


hello. my gen2 1.3 auto no mod. last time fc is 7.1l -100km now become 11.9l-100km. very high fc and no power. anyone know how to solve it ? thanks

4 Pages « < 2 3 4Top
 

Change to:
| Lo-Fi Version
0.0181sec    0.46    5 queries    GZIP Disabled
Time is now: 4th December 2022 - 10:36 AM