Welcome Guest ( Log In | Register )

Please provide proper description when you report a post. Report button abuse will earn you an automatic warn + suspension.
 
RSS feedBump TopicReply to this topicStart new topicStart Poll

Outline · [ Standard ] · Linear+

> Over heating in my iswara..., can smell burninng smell

param124
post Apr 3 2008, 06:35 PM


Getting Started
**
Group: Junior Member
Posts: 115

Joined: May 2007


Yesterday morning i did my routine black oil and water check...but...this time i forgot to cap my radiator cap...drove to uni and on way back in evening it was raining...could smell burning smell than saw temperature...like nearly to red point on my iswara 1.5s.

I stopped at petrol station and added water slowly into radiator after that....bit by bit....then temperature went back too normal...

but now when i turn off my engine it doesnt turn off immediately when i switch key off there is like 1 second pause before it does.....

Can this be due too over heating due to my carelessness...can someone advice...izzit an engine damage?

Any advice from sifu's out there is uch appreciated...

This post has been edited by param124: Apr 3 2008, 08:16 PM
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
ryan_hustler
post Apr 3 2008, 07:52 PM


Actum Est
*****
Group: Senior Member
Posts: 886

Joined: Aug 2007
From: Subang/Melaka


QUOTE(param124 @ Apr 3 2008, 06:35 PM)
but now when i turn off my engine it does turn off immediately when i switch key off there is like 1 second pause before it does.....
*
So does it turn off or doesnt turn off immediately?Because you said it does turn off but then theres a 1sec pause which means it doesnt..???


Added on April 3, 2008, 7:54 pmBTW, u check your radiator water by opening the radiator cap? sweat.gif

This post has been edited by ryan_hustler: Apr 3 2008, 07:54 PM
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
param124
post Apr 3 2008, 08:16 PM


Getting Started
**
Group: Junior Member
Posts: 115

Joined: May 2007


QUOTE(ryan_hustler @ Apr 3 2008, 07:52 PM)
So does it turn off or doesnt turn off immediately?Because you said it does turn off but then theres a 1sec pause which means it doesnt..???


Added on April 3, 2008, 7:54 pmBTW, u check your radiator water by opening the radiator cap? sweat.gif
*
Sorry bro i was unclear...it DOESNT turn off immediately as it should....there is a slight delay...

Btw i forget top CAP it back in the morning...after checking the water...so when temp went up i open my front...and saw noo cap..on the radiator...
i started poring water into my radiator....stim...was all over....so i did it slowly....bit by bit...till it filled...took like half hour...


hope its clear now rclxub.gif notworthy.gif

pls help cry.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
mytrader
post Apr 3 2008, 09:25 PM


Casual
***
Group: Junior Member
Posts: 320

Joined: Feb 2008


Did you start your engine immediately after filling up with water ? Or worse, was your engine running when you were adding in water ?


User is offlineProfile CardPM
Go to the top of the page
+Quote Post
singchaii
post Apr 3 2008, 09:38 PM


~N0 Pa|n,N0 Ga|N~
*******
Group: Senior Member
Posts: 7,834

Joined: Sep 2004
From: Pandan Jaya,KL



QUOTE(param124 @ Apr 3 2008, 06:35 PM)
Yesterday morning i did my routine black oil and water check...but...this time i forgot to cap my radiator cap...drove to uni and on way back in evening it was raining...could smell burning smell than saw temperature...like nearly to red point on my iswara 1.5s.

I stopped at petrol station and added water slowly into radiator after that....bit by bit....then temperature went back too normal...

but now when i turn off my engine it doesnt turn off immediately when i switch key off there is like 1 second pause before it does.....

Can this be due too over heating due to my carelessness...can someone advice...izzit an engine damage?

Any advice from sifu's out there is uch appreciated...
*
Need to retune the timing. The timing already run... icon_rolleyes.gif icon_rolleyes.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
the_catacombs
post Apr 4 2008, 04:38 AM


8 stars wooo....
********
Group: Senior Member
Posts: 10,975

Joined: Jan 2003
From: disini disana


try again tomolo... if problem still persist, check ur timing, might lari adi.... last resort, engine damage....
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
sakaic
post Apr 4 2008, 06:53 AM


Enthusiast
*****
Group: Senior Member
Posts: 836

Joined: Jun 2005
no need to set timing.

there is engine damage. Its called over-run. The engine is permanently overheating internally. maybe head gasket leaking adi.
User is online!Profile CardPM
Go to the top of the page
+Quote Post
GoldenHawk
post Apr 4 2008, 10:08 AM


The Forgotten
*****
Group: Senior Member
Posts: 966

Joined: Jan 2003
From: Malacca



QUOTE(ryan_hustler @ Apr 3 2008, 07:52 PM)
BTW, u check your radiator water by opening the radiator cap? sweat.gif
*

How you check your radiator fluid? unsure.gif

QUOTE(sakaic @ Apr 4 2008, 06:53 AM)
no need to set timing.

there is engine damage. Its called over-run. The engine is permanently overheating internally. maybe head gasket leaking adi.
*

Dieseling. Usually happens when the internal temp is too hot that it continues running without the spark from the plug. Wiki it.
Try checking the black oil again. If you see brownish froth or residue, then you might have a leaking gasket. Get it replaced.
Else, you can try filing up your radiator fluid + coolant again. Either DIY properly or get the workshop to do it.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
ryan_hustler
post Apr 4 2008, 02:05 PM


Actum Est
*****
Group: Senior Member
Posts: 886

Joined: Aug 2007
From: Subang/Melaka


QUOTE(GoldenHawk @ Apr 4 2008, 10:08 AM)
How you check your radiator fluid? unsure.gif
*
Thought TS opened the radiator cap while the car was overheating..my bad blush.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
param124
post Apr 4 2008, 04:21 PM


Getting Started
**
Group: Junior Member
Posts: 115

Joined: May 2007


QUOTE(mytrader @ Apr 3 2008, 09:25 PM)
Did you start your engine immediately after filling up with water ? Or worse, was your engine running when you were adding in water ?
*
QUOTE(the_catacombs @ Apr 4 2008, 04:38 AM)
try again tomolo... if problem still persist, check ur timing, might lari adi.... last resort, engine damage....
*

rclxub.gif


QUOTE(sakaic @ Apr 4 2008, 06:53 AM)
no need to set timing.

there is engine damage. Its called over-run. The engine is permanently overheating internally. maybe head gasket leaking adi.
*
QUOTE(ryan_hustler @ Apr 4 2008, 02:05 PM)
Thought TS opened the radiator cap while the car was overheating..my bad blush.gif
*
Bro....neva start immmediately the engine....i put water in it slowly....took hallf hour too filll the radiator...

Timing is sljghtly higher now....serviced my car today....noo prob ...


Bro wats over run? how do i check its permeneantly over heating wat is the sight effect on my car?
Is timing for iswara at half way through the meter bad or normal? rclxub.gif

Thanks...for all replies...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
ryan_hustler
post Apr 4 2008, 10:17 PM


Actum Est
*****
Group: Senior Member
Posts: 886

Joined: Aug 2007
From: Subang/Melaka


QUOTE(param124 @ Apr 4 2008, 04:21 PM)
rclxub.gif
Bro....neva start immmediately the engine....i put water in it slowly....took hallf hour too filll the radiator...

Timing is sljghtly higher now....serviced my car today....noo prob ...
Bro wats over run? how do i check its permeneantly over heating wat is the sight effect on my car?
Is timing for iswara at half way through the meter bad or normal? rclxub.gif

Thanks...for all replies...
*
usually the timing is about 800rpm without air cond..
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
flyingteeku
post Apr 5 2008, 12:18 AM


Regular
******
Group: Senior Member
Posts: 1,933

Joined: Dec 2006


QUOTE(ryan_hustler @ Apr 4 2008, 10:17 PM)
usually the timing is about 800rpm without air cond..
*
wah..so low...if on air cond, maa enjin like wanna die...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
N's
post Apr 5 2008, 12:54 AM


Regular
******
Group: Senior Member
Posts: 1,091

Joined: Feb 2007
QUOTE(flyingteeku @ Apr 5 2008, 12:18 AM)
wah..so low...if on air cond, maa enjin like wanna die...
*
on aircon normally will rise la.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Lester1987
post Apr 5 2008, 08:22 AM


Regular
******
Group: Senior Member
Posts: 1,810

Joined: Jan 2007
From: KL staying in JB


i had a wira 1.5 that day i cought in an accident, i tot nothing was wrong as i saw 1 of my front lights pecah oni. later, i notice my temperature start to rise, before i got the chance to find a place to park, my car temperature went untill red and mati by it self already. then i wait for a while, when the temperature down a bit, i drive again. then the temperature rose again and i stop to check the engine, only then i notice my radiator no water and already bocor. i notice that the "minyak hitam" start leaking from the engine and got a strong burning smell from it, so i top up water and go to a workshop to change the radiator. now, it seems to be normal, but before this happens, enerytime i go genting , my car temperature sure will rise. izzit something wrong with my engine?? Wira go Genting shouldn't have problem rite?? BTW, mine is 1.5 (A). all sifu, please advice
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
ryan_hustler
post Apr 5 2008, 08:50 AM


Actum Est
*****
Group: Senior Member
Posts: 886

Joined: Aug 2007
From: Subang/Melaka


QUOTE(Lester1987 @ Apr 5 2008, 08:22 AM)
i had a wira 1.5 that day i cought in an accident, i tot nothing was wrong as i saw 1 of my front lights pecah oni. later, i notice my temperature start to rise, before i got the chance to find a place to park, my car temperature went untill red and mati by it self already. then i wait for a while, when the temperature down a bit, i drive again. then the temperature rose again and i stop to check the engine, only then i notice my radiator no water and already bocor. i notice that the "minyak hitam" start leaking from the engine and got a strong burning smell from it, so i top up water and go to a workshop to change the radiator. now, it seems to be normal, but before this happens, enerytime i go genting , my car temperature sure will rise. izzit something wrong with my engine?? Wira go Genting shouldn't have problem rite?? BTW, mine is 1.5 (A). all sifu, please advice
*
u said noticed the engine oil leaking,u didnt check the engin at the workshop?check gasket,oil seals and stuff?Never top up engine oil?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Lester1987
post Apr 5 2008, 09:34 AM


Regular
******
Group: Senior Member
Posts: 1,810

Joined: Jan 2007
From: KL staying in JB


not so sure. i pass the car to my mom and ask her go repair for me.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
ryan_hustler
post Apr 5 2008, 08:02 PM


Actum Est
*****
Group: Senior Member
Posts: 886

Joined: Aug 2007
From: Subang/Melaka


oh ok..check the dipstick for engin oil level..should be between the high and low mark..
Look around the engine and below the car for black oil leaks.
Remove spark plugs and see if they are coated in oil as well..
Also remove engin oil cap and smell it to see if got and odd or burnt smell..
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Bump TopicReply to this topicTopic OptionsStart new topic
 

Switch to:
| Lo-Fi Version
0.0735sec    4.97    5 queries    GZIP Disabled
Time is now: 16th April 2014 - 03:40 PM