Welcome Guest ( Log In | Register )

Outline · [ Standard ] · Linear+

> 03' W211 Restoration Progress

views
     
dumay
post Jun 15 2021, 08:41 AM

New Member
*
Junior Member
21 posts

Joined: Oct 2020
fellow W211 fan here .. used to own a 2007 E280 avantgarde that i bought with 150,000 km mileage .. luckily managed to get out before the m273 timing chain issue came up ..

This post has been edited by dumay: Jun 15 2021, 09:40 AM
ayamxxx
post Jun 15 2021, 09:50 AM

Regular
******
Senior Member
1,445 posts

Joined: Apr 2010
From: Kuala Lumpur



QUOTE(dumay @ Jun 15 2021, 08:41 AM)
fellow W211 fan here .. used to own a 2007 E280 avantgarde that i bought with 150,000 km mileage .. luckily managed to get out before the m273 timing chain issue came up ..
*
Any sign to detect b4 this problem come out? Got friend eying w211 E230 v6 201hp
dumay
post Jun 15 2021, 10:29 AM

New Member
*
Junior Member
21 posts

Joined: Oct 2020
QUOTE(ayamxxx @ Jun 15 2021, 09:50 AM)
Any sign to detect b4 this problem come out? Got friend eying w211 E230 v6 201hp
*
sorry it's M272 engine .. mine had check engine light and did a scan and it will tell you camshaft error or something .. forgot the code already .. but I changed my solenoid coils and manage to drive it for awhile more ..

the symptoms will be some faint chain sounds when you cold start .. it will come occasionally during accelerations too.

This is manufacturer's defect issue and only affected those m272 engines built in 2007 or earlier.

If your friend is eyeing the E230, malaysia only sold it around 2008 and this issue already have been resolved so don't need to worry about it .. generally it's a pretty reliable engine. mine i drove it till 165,000 still silky smooth save for the occasional CEL from the camshafts
ayamxxx
post Jun 15 2021, 04:51 PM

Regular
******
Senior Member
1,445 posts

Joined: Apr 2010
From: Kuala Lumpur



QUOTE(dumay @ Jun 15 2021, 10:29 AM)
sorry it's M272 engine .. mine had check engine light and did a scan and it will tell you camshaft error or something .. forgot the code already .. but I changed my solenoid coils and manage to drive it for awhile more ..

the symptoms will be some faint chain sounds when you cold start .. it will come occasionally during accelerations too.

This is manufacturer's defect issue and only affected those m272 engines built in 2007 or earlier.

If your friend is eyeing the E230, malaysia only sold it around 2008 and this issue already have been resolved so don't need to worry about it .. generally it's a pretty reliable engine. mine i drove it till 165,000 still silky smooth save for the occasional CEL from the camshafts
*
Yeah i studied it as well. Price is considering ok now. It last batches of w211 in Malaysia and get the best version of command aps (still cannot compare to nowadays hu which much better).

The e240 2.6 v6 kinda use old tech while this e230 2.5 v6 had vvt both iinm and 201 hp vs 170+ on e240.
ktek
post Jun 16 2021, 04:19 PM

워터파크
*******
Senior Member
9,858 posts

Joined: Jul 2006
QUOTE(ayamxxx @ Jun 15 2021, 04:51 PM)
Yeah i studied it as well. Price is considering ok now. It last batches of w211 in Malaysia and get the best version of command aps (still cannot compare to nowadays hu which much better).
The e240 2.6 v6 kinda use old tech while this e230 2.5 v6 had vvt both iinm and 201 hp vs 170+ on e240.
*
yup 2.6 sohc m112 robust tech really trouble free

 

Change to:
| Lo-Fi Version
0.0163sec    0.81    5 queries    GZIP Disabled
Time is now: 2nd August 2021 - 05:26 AM