Welcome Guest ( Log In | Register )

Outline · [ Standard ] · Linear+

> Saga 2010 BLM gear shift issue, Car gear shift won’t change to P

views
     
TSEssa95 P
post May 18 2021, 11:49 PM, updated 2 months ago

New Member
*
Probation
43 posts

Joined: Oct 2020


Hi everyone,

Suddenly, my gear shift won’t allow me to change to “P” and I’m using “N” instead when I park my car.
I tried to push it as hard as it makes sense but it won’t go all the way to “P”.
I can’t find any gear shift lock so I’m not sure if I can fix it myself or I need to see a mechanic?
Please advise guys.
Thanks in advance!

TSEssa95 P
post May 19 2021, 02:57 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(ImSIEBEL @ May 19 2021, 01:59 AM)

*
The video isn’t available sad.gif
TSEssa95 P
post May 19 2021, 05:17 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(ImSIEBEL @ May 19 2021, 03:27 PM)
I just google saga blm gear stuck and came up that video. My friend had the same issue
*
Thanks for that. I actually checked all the videos but I don’t see the “lock” button they’re referring to it. Not sure if I can open the cover or not to look for it.
TSEssa95 P
post May 19 2021, 05:18 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(croydon @ May 19 2021, 03:50 PM)

*
Thanks for sending this. I actually don’t have the same layout for the gear shift as I don’t see the “lock” button/functionality that he’s using.
TSEssa95 P
post May 20 2021, 03:19 AM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(kdr93 @ May 19 2021, 05:53 PM)
Did you chnage any items in your engine bay, like battery or something.

I had this issue in my car last time, turns out the new battery tray i installed was physically blocking the selector plate at the gb 😅

Just check the selector area in your engine bay, could be as simple as something stuck there. To give you an idea where it is, ask someone to shift from R to N to D, you should see a lever moving.

Watch what happens as it is pushed into P, it could just be somthing blocking the lever.
*
That’s a great idea. I will it for sure. However, I didn’t change anything recently and it just happened out of the blue. This month is tight so I want to avoid going to the mechanic.
Is it okay to park using the “N” instead of “P” for a few weeks?
TSEssa95 P
post May 20 2021, 11:46 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(cempedaklife @ May 20 2021, 06:56 AM)
You better keep a few bricks in your car and put them under your tyres when you park.
*
I’ll avoid steep parkings for the time being. Thanks 🙏🏼
TSEssa95 P
post May 20 2021, 11:48 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(zeng @ May 20 2021, 08:06 AM)
Yes, I habitually select N instead of P for overnight parking..... for years in Wira and Avanza.
I suppose your Saga wiring/starting circuit 'permits' similar behaviour.
Mind your handbrake though, making sure it is properly engaged.

Automatic Transmission Parking Pawl
*
Thanks! I actually parked using the N on a very steep road and there was no issues. I’ll do that for now 👍🏼

TSEssa95 P
post May 21 2021, 04:36 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(bo093 @ May 21 2021, 08:19 AM)
If you can enter the rest of the gears (ie R,N,D,3,2 and L)
Likely the cable need some adjustment. Is at the gearbox.
Loosen the cable, push the gear selector(gearbox side) to P and push the gear lever to P. Then tighten it.
*
I’ll try to check on that and see if I can do that. Thanks!
TSEssa95 P
post May 21 2021, 04:39 PM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(abubin @ May 21 2021, 11:20 AM)
It helps if you can take a picture of your gear knob surrounding so people can see and help.
*
user posted image

It looks like this (got it online). It won’t go up to “P” gear
TSEssa95 P
post Jun 10 2021, 03:17 AM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(tctham @ Jun 8 2021, 06:55 PM)
happened to me LOOONG ago (when my saga BLM is still within warranty)
Basically when i shift it out of P, i heard a cracking/snapping sound. Then i cannot shift it to P. I can even hear something rattling inside. I drove to SC and told them. they told me to leave overnight, i say it's obviously something at the lever broke. and i asked them to resolve it for me. in the end, they took a used parking level, and replaced it temporarily. Then when new stock arrived, they replaced the new one. Don't know the cost as i claimed warranty, but my issue is obviously something small broke at the parking lever.

is your symptom the same?
*
Actually, mine was working without any issues and after I went to Putrajaya (40 minutes drive overall) then when I came back to my place the lever won’t go to “P” anymore. No cracking and no similar issue. It was quite sudden. Now it’s MCO again and I can’t go see my mechanic sad.gif
TSEssa95 P
post Jun 11 2021, 03:08 AM

New Member
*
Probation
43 posts

Joined: Oct 2020


QUOTE(tctham @ Jun 10 2021, 02:21 PM)
sads, then i don't think your problem is same as mine. and as such, the resolution may not be that straight forward. wish you all the best and keep us posted.
*
Thanks a lot. A friend told me to try and detach the battery for a bit and see. I’ll try that and if it doesn’t work. I have no choice but going to a mechanic.

 

Change to:
| Lo-Fi Version
0.0202sec    0.66    6 queries    GZIP Disabled
Time is now: 30th July 2021 - 08:44 AM